Some users seeing slowness within Bridge
Incident Report for Bridge
Resolved
This incident has been resolved.
Posted Mar 23, 2021 - 17:54 UTC
Investigating
Some users are currently experiencing slowness or degraded performance within the Bridge platform. Our Ops team is currently investigating the issue and we'll provide an update as soon as we can. We apologize for the trouble!
Posted Mar 23, 2021 - 17:18 UTC
This incident affected: Bridge Learn (Courses), Bridge Perform (1:1s), Bridge Career (Development Plan), and Bridge Engage.