Bridge Support Phone Number Currently Unavailable
Incident Report for Bridge
Resolved
We've been able to correct the issue with the phone system that was preventing users from accessing Bridge Support via telephone. Thank you for your patience during this time and we apologize for the inconvenience this had caused!
Posted 10 months ago. Apr 25, 2018 - 21:12 UTC
Identified
We've identified an issue with our vendors that is preventing users from contacting Bridge Support via telephone. We our working to resolve the issue as quickly as possible. In the meantime, you can reach out to us via email at support@bridgeapp.com. Or you can reach the team at (443) 637-6662
Posted 10 months ago. Apr 25, 2018 - 20:59 UTC
This incident affected: Bridge Support Channels.